Gets fabrication connector identifiers from the fabrication configuration, filtered by shape and domain.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- domain
- Type: Autodesk.Revit.DB ConnectorDomainType
ConnectorDomainType to filter by. Pass ConnectorDomainType.Undefined to get all connector domains.
- shape
- Type: Autodesk.Revit.DB ConnectorProfileType
ConnectorProfileType to filter by. Pass ConnectorProfileType.Invalid to get all shapes.
Return Value
All the fabrication connector identifiers, filtered by shape and domain. The return will be empty if no connectors are found.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |