Rotate a face/edge/curve/vertex of the form, by a specified angle around a given axis.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- subElementReference
- Type: Autodesk.Revit.DB Reference
The geometry reference of face/edge/curve/vertex
- axis
- Type: Autodesk.Revit.DB Line
An unbounded line that represents the axis of rotation.
- angle
- Type: System Double
The angle, in radians, by which the element is to be rotated around the specified axis.