Sets graphic overrides for a category in view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- categoryId
- Type: Autodesk.Revit.DB ElementId
Category to be overridden
- overrideGraphicSettings
- Type: Autodesk.Revit.DB OverrideGraphicSettings
Object representing all graphic overrides of the category categoryId in view.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Category cannot be overridden. -or- Fill pattern must be a drafting pattern. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | The view type does not support Visibility/Graphics Overriddes. |