Retrieves the caption for a specific resolution type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- type
- Type: Autodesk.Revit.DB FailureResolutionType
The resolution type.
Return Value
The caption of the resolution.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Resolution of the type is not applicable to the failure. |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions InvalidOperationException | FailureDefinition does not have any resolutions. |