Adds the specified vector to this vector and returns the result.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- source
-
Type:
Autodesk.Revit.DB
XYZ
The vector to add to this vector.
Return Value
The vector equal to the sum of the two vectors.Remarks
The added vector is obtained by adding each coordinate of the specified vector
to the corresponding coordinate of this vector.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when source is a null reference ( Nothing in Visual Basic) . |