BeforeExecutedEventArgs Class


The event arguments used by AddInCommandBinding's BeforeExecuted event.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2014

Syntax

C#
public class BeforeExecutedEventArgs : CommandEventArgs
Visual Basic
Public Class BeforeExecutedEventArgs _
	Inherits CommandEventArgs
Visual C++
public ref class BeforeExecutedEventArgs : public CommandEventArgs

Remarks

This event is cancellable. If your callback sets the Cancel property to true, the command will not execute.

Inheritance Hierarchy

See Also