Sets visibility for a workset in this view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- worksetId
- Type: Autodesk.Revit.DB WorksetId
Id of the workset.
- visible
- Type: Autodesk.Revit.DB WorksetVisibility
The visibility of the workset.
Remarks
It works even when the workset is closed. This settings overrules implicit visibility of the workset (for this particular view only).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | There is no workset with this Id in the document associated with this view. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |