IsAllowedDimensionStyle Method


Checks if the dimension style can be used with multi-reference annotations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public bool IsAllowedDimensionStyle(
	ElementId dimensionStyleId
)
Visual Basic
Public Function IsAllowedDimensionStyle ( _
	dimensionStyleId As ElementId _
) As Boolean
Visual C++
public:
bool IsAllowedDimensionStyle(
	ElementId^ dimensionStyleId
)

Parameters

dimensionStyleId
Type: Autodesk.Revit.DB ElementId
The dimension style to check.

Return Value

True if the dimension style can be used by multi-reference annotations.

Remarks

Only linear dimension styles are allowed.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also