SetOffsetForIntersectingReference Method


Sets offset for the intersecting reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public void SetOffsetForIntersectingReference(
	ElementId intersectingReference,
	double offset
)
Visual Basic
Public Sub SetOffsetForIntersectingReference ( _
	intersectingReference As ElementId, _
	offset As Double _
)
Visual C++
public:
void SetOffsetForIntersectingReference(
	ElementId^ intersectingReference, 
	double offset
)

Parameters

intersectingReference
Type: Autodesk.Revit.DB ElementId
The intersecting reference that will be offset.
offset
Type: System Double
The new offset.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException PartMaker does not use the specified intersecting reference.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also