GetColumnAttachment Method (FamilyInstance, Int32)


Look up a column attachment. There is at most one attachment on the base and one on the top.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public static ColumnAttachment GetColumnAttachment(
	FamilyInstance column,
	int baseOrTop
)
Visual Basic
Public Shared Function GetColumnAttachment ( _
	column As FamilyInstance, _
	baseOrTop As Integer _
) As ColumnAttachment
Visual C++
public:
static ColumnAttachment^ GetColumnAttachment(
	FamilyInstance^ column, 
	int baseOrTop
)

Parameters

column
Type: Autodesk.Revit.DB FamilyInstance
A column.
baseOrTop
Type: System Int32
0 for base, 1 for top.

Return Value

The column attachment for the base or top of the column, or a null reference ( Nothing in Visual Basic) if that end of the column is unattached.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions ArgumentOutOfRangeException baseOrTop must be either 0 or 1.

See Also