UpdateMultiple Method (Document, IList(ElementId), IList(PathOfTravelCalculationStatus))


Updates the specified paths of travel by recalculating each path using their original start and end points and provides creation result statuses.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since: 2020

Syntax

C#
public static int UpdateMultiple(
	Document adoc,
	IList<ElementId> elementsToUpdate,
	out IList<PathOfTravelCalculationStatus> resultStatus
)
Visual Basic
Public Shared Function UpdateMultiple ( _
	adoc As Document, _
	elementsToUpdate As IList(Of ElementId), _
	<OutAttribute> ByRef resultStatus As IList(Of PathOfTravelCalculationStatus) _
) As Integer
Visual C++
public:
static int UpdateMultiple(
	Document^ adoc, 
	IList<ElementId^>^ elementsToUpdate, 
	[OutAttribute] IList<PathOfTravelCalculationStatus>^% resultStatus
)

Parameters

adoc
Type: Autodesk.Revit.DB Document
Document of elements to be updated.
elementsToUpdate
Type: System.Collections.Generic IList ElementId
The list of ElementId of the paths to update.
resultStatus
Type: System.Collections.Generic IList PathOfTravelCalculationStatus %
Result statuses of each path of travel creation. The order of statuses corresponds to the order of elements in the array passed to the function.

Return Value

number of successfully updated elements

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also