AddSubFolder Method (String, String)


Adds a subfolder to the folder path with the given name and icon type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since: 2019.1

Syntax

C#
public void AddSubFolder(
	string folderName,
	string iconPath
)
Visual Basic
Public Sub AddSubFolder ( _
	folderName As String, _
	iconPath As String _
)
Visual C++
public:
void AddSubFolder(
	String^ folderName, 
	String^ iconPath
)

Parameters

folderName
Type: System String
The name of the folder.
iconPath
Type: System String
Icon path.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The folderName is not a valid folder name used to display in Revit external resource browse UI. The name should be a unique non-empty short name and it should not contain any invalid character of \\/:*?"<>|. The length of combined path(server name + folder path) should not exceeds 259.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also