CheckFamily Method


Check that the loaded family has its content document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)

Syntax

C#
public static bool CheckFamily(
	Document ADoc,
	ElementId familyId
)
Visual Basic
Public Shared Function CheckFamily ( _
	ADoc As Document, _
	familyId As ElementId _
) As Boolean
Visual C++
public:
static bool CheckFamily(
	Document^ ADoc, 
	ElementId^ familyId
)

Parameters

ADoc
Type: Autodesk.Revit.DB Document
The host document.
familyId
Type: Autodesk.Revit.DB ElementId
The id of the family to check.

Return Value

Returns true if the family has its content document.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also