SplitStraight Method


Splits the straight into two at the passed in point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2017 Subscription Update

Syntax

C#
public ElementId SplitStraight(
	Document document,
	ElementId partId,
	XYZ position
)
Visual Basic
Public Function SplitStraight ( _
	document As Document, _
	partId As ElementId, _
	position As XYZ _
) As ElementId
Visual C++
public:
ElementId^ SplitStraight(
	Document^ document, 
	ElementId^ partId, 
	XYZ^ position
)

Parameters

document
Type: Autodesk.Revit.DB Document
The document.
partId
Type: Autodesk.Revit.DB ElementId
Id of the straight to split.
position
Type: Autodesk.Revit.DB XYZ
The position to split in the straight.

Return Value

Returns the ElementId of the new straight.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The part is not a straight. -or- The position is not on the straight.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also