Creates a new instance of the FabricationPartSizeMap class.
Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2018.2
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- size
- Type: System String
The size display string for the straight that can be used by the user interface.
- widthDiameter
- Type: System Double
The width or diameter of the straight.
- depth
- Type: System Double
The depth of the straight.
- isProductList
- Type: System Boolean
Set if the straight a product list or not.
- profileType
- Type: Autodesk.Revit.DB ConnectorProfileType
Set the shape of the straight.
- serviceId
- Type: System Int32
Set the service identifier of the straight.
- groupId
- Type: System Int32
Set the group identifier of the straight.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |