GetVertex Method


Return a reference to one of the vertices in the definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012

Syntax

C#
public RebarShapeVertex GetVertex(
	int vertexIndex
)
Visual Basic
Public Function GetVertex ( _
	vertexIndex As Integer _
) As RebarShapeVertex
Visual C++
public:
RebarShapeVertex^ GetVertex(
	int vertexIndex
)

Parameters

vertexIndex
Type: System Int32
Index of the vertex (0 to NumberOfVertices - 1).

Return Value

The requested vertex.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException vertexIndex is not between 0 and NumberOfVertices.

See Also