GetDefaultHookOrientation Method


Get the hook orientation.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014

Syntax

C#
public RebarHookOrientation GetDefaultHookOrientation(
	int index
)
Visual Basic
Public Function GetDefaultHookOrientation ( _
	index As Integer _
) As RebarHookOrientation
Visual C++
public:
RebarHookOrientation GetDefaultHookOrientation(
	int index
)

Parameters

index
Type: System Int32
0 for the starting hook, 1 for the ending hook.

Remarks

Replaces the method GetHookOrientation() from prior releases.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException index must be 0 or 1.

See Also