IsHidden Method


Identifies if the element has been permanently hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public bool IsHidden(
	View pView
)
Visual Basic
Public Function IsHidden ( _
	pView As View _
) As Boolean
Visual C++
public:
bool IsHidden(
	View^ pView
)

Parameters

pView
Type: Autodesk.Revit.DB View

Remarks

This does not determine if the element is hidden as a result of temporary hide/isolate, view sectioning, view crop box, or other operations that can cause elements not to be visible. To hide or unhide an element, use the Hide() and Unhide() method of View .

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException Thrown when argument is a null reference ( Nothing in Visual Basic) .

See Also