Provides access to value as a string with unit in the given family parameter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- familyParameter
- Type: Autodesk.Revit.DB FamilyParameter
Return Value
The string that represents the parameter value with unit.Remarks
The method only applies to parameters of value types. If the parameter has no value or does not contain a numeric value, the method returns a null reference ( Nothing in Visual Basic) .
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when the input argument-"familyParameter"-is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions ArgumentException | Thrown if the input argument-"familyParameter"-is invalid. |