Changes the double-click action associated with a specified target.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- target
- Type: Autodesk.Revit.UI DoubleClickTarget
The double-click target whose action will be changed.
- action
- Type: Autodesk.Revit.UI DoubleClickAction
The action to assign to the target.
Remarks
This change will be stored in the user's profile and will affect future sessions of Revit in addition to the current session.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The specified action is not valid for the target element. |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |