Returns the angle between this vector and the specified vector projected to the specified plane.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- right
-
Type:
Autodesk.Revit.DB
XYZ
The specified vector.
- normal
-
Type:
Autodesk.Revit.DB
XYZ
The normal vector that defines the plane.
Return Value
The real number between 0 and 2*PI equal to the projected angle between the two vectors.Remarks
The angle is projected onto the plane orthogonal to the specified normal vector,
counterclockwise with the normal pointing upwards.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when right or normal is a null reference ( Nothing in Visual Basic) . |