Appends an Item to the RebarContainer. Fills its data on base of the Rebar.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- rebarShape
- Type: Autodesk.Revit.DB.Structure RebarShape
A RebarShape element that defines the shape of the rebar. A RebarShape element matches curves and hooks. A RebarShape element provides RebarStyle of the rebar.
- barType
- Type: Autodesk.Revit.DB.Structure RebarBarType
A RebarBarType element that defines bar diameter, bend radius and material of the rebar.
- startHook
- Type: Autodesk.Revit.DB.Structure RebarHookType
A RebarHookType element that defines the hook for the start of the bar. If this parameter is a null reference ( Nothing in Visual Basic) , it means to create a rebar with no hook.
- endHook
- Type: Autodesk.Revit.DB.Structure RebarHookType
A RebarHookType element that defines the hook for the end of the bar. If this parameter is a null reference ( Nothing in Visual Basic) , it means to create a rebar with no hook.
- normal
- Type: Autodesk.Revit.DB XYZ
The normal to the plane that the rebar curves lie on.
- curves
- Type: System.Collections.Generic IList Curve
An array of curves that define the shape of the rebar curves. They must belong to the plane defined by the normal and origin. Bends and hooks should not be included in the array of curves.
- startHookOrient
- Type: Autodesk.Revit.DB.Structure RebarHookOrientation
Defines the orientation of the hook plane at the start of the rebar with respect to the orientation of the first curve and the plane normal. Only two values are permitted: Value = Right: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = Left: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."
- endHookOrient
- Type: Autodesk.Revit.DB.Structure RebarHookOrientation
Defines the orientation of the hook plane at the end of the rebar with respect to the orientation of the last curve and the plane normal. Only two values are permitted: Value = Right: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = Left: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."
Return Value
The Rebar Container Item.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The input curves is empty. -or- The input curves contains at least one curve which is not a bound Line or bound Arc and is not supported for this operation. -or- curves do not form a valid CurveLoop. -or- The input curves contains at least one helical curve and is not supported for this operation. -or- The rebarShape has End Treatments |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | normal has zero length. -or- A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions ArgumentsInconsistentException | curves contains non-fillet arcs with radii that are less than the minimum bend radius for the RebarBarType and RebarShape style. |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Structural. |
Autodesk.Revit.Exceptions InvalidOperationException | rebarShape does not match curves. |