The entry point to the native IFC import function. Processes the main IfcProject and creates appropriate Revit elements.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- ifcProject
- Type: Autodesk.Revit.DB.IFC IFCAnyHandle
The IfcProject containing the entities in the IFC file.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |