Sets the reference that determines the origin of this DisplacementPath.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- displacementElement
- Type: Autodesk.Revit.DB DisplacementElement
The element id of a DisplacementElement.
- reference
- Type: Autodesk.Revit.DB Reference
A reference of an edge or a curve in the GRep of the element corresponding to elemId.
- param
- Type: System Double
An parameter used to specify a point on the edge.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The value param should lie in the range [0,1]. -or- reference does not represent an edge or curve belonging to an element displaced by displacementElement. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |