Creates a new topography surface element from facets and adds it to the document.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2019.2
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document to be modified.
- points
- Type: System.Collections.Generic IList XYZ
A collection of points. The points represent an enclosed area in the XY plane.
- facets
- Type: System.Collections.Generic IList PolymeshFacet
Triangle facets composing a polygon mesh. Every facet contains 3 integers representing vertex indices.
Return Value
The new topography surface.Remarks
The document will be regenerated during the creation of this topography surface element. The topography surface created by facet cannot modify its triangle points and facets.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | document is not a project document. -or- There are invalid facets. Facets with more than two points with same x, y are not allowed. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions ModificationOutsideTransactionException | The document has no open transaction. |