Constructs a new instance of a DimensionEqualityLabelFormatting object with specified settings.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2017 Subscription Update
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- leadingSpaces
- Type: System Int32
The number of spaces to include before the parameter value.
- prefix
- Type: System String
The prefix to include before the parameter value.
- labelType
- Type: Autodesk.Revit.DB LabelType
The parameter value to be shown.
- suffix
- Type: System String
The suffix to include after the parameter value.
- formatOptions
- Type: Autodesk.Revit.DB FormatOptions
The format options to use for the parameter value.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |