Checks whether the input id represents a profile which can be used as the profile of this non-continuous rail.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2019
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- profileId
- Type: Autodesk.Revit.DB ElementId
The profile Id to be checked.
Return Value
True if the ElementId refers to a valid NonContinuousRail profile, false otherwise.Remarks
InvalidElementId is considered a valid NonContinuousRail profile (the default profile).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |