Creates a transform that represents a rotation about the given axis at the specified point.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- axis
- Type: Autodesk.Revit.DB XYZ
The rotation axis.
- angle
- Type: System Double
The angle.
- origin
- Type: Autodesk.Revit.DB XYZ
The origin point.
Return Value
The new transform.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The given value for angle is not finite |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | axis has zero length. |