Checks whether a bar exists at the specified position.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- barPosition
- Type: System Int32
A bar position index between 0 and NumberOfBarPositions-1.
Return Value
Always returns true, since it is not possible to de-activate the first or last bars in a Rebar set that is part of Area or Path Reinforcement. (see includeFirstBar and includeLastBar methods for Rebar)Remarks
Returns true, unless the bar position is the first or last in the set and it is suppressed by IncludeFirstBar or IncludeLastBar. For the current implementation of RebarInSystem, this property will always return true, since the first and last bars in a RebarInSystem set cannot be suppressed. However, it is included in the RebarInSystem interface for consistency with the Rebar class
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | barPosition is not in the range [ 0, NumberOfBarPositions-1 ]. |