RemoveReferences Method


Removes references from the connection. All references in an array should belong to the connection.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017

Syntax

C#
public void RemoveReferences(
	IList<Reference> picks
)
Visual Basic
Public Sub RemoveReferences ( _
	picks As IList(Of Reference) _
)
Visual C++
public:
void RemoveReferences(
	IList<Reference^>^ picks
)

Parameters

picks
Type: System.Collections.Generic IList Reference
The array containing picks to be removed.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException One or more picks was not permitted to be removed from the connection. Picks should be members of the connection.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also