A class to assist in defining rebar shapes.
A RebarShape element needs exactly one RebarShapeDefinition.
Namespace:
Autodesk.Revit.DB.Structure
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2009
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
A RebarShapeDefinition stores a set of Rebar Shape parameters. Each parameter
may be associated with:
- One or more RebarShapeConstraints; or
- A formula; or
- Neither of the above.
Inheritance Hierarchy
System
Object
Autodesk.Revit.DB.Structure RebarShapeDefinition
Autodesk.Revit.DB.Structure RebarShapeDefinitionByArc
Autodesk.Revit.DB.Structure RebarShapeDefinitionBySegments
Autodesk.Revit.DB.Structure RebarShapeDefinition
Autodesk.Revit.DB.Structure RebarShapeDefinitionByArc
Autodesk.Revit.DB.Structure RebarShapeDefinitionBySegments