This function takes a potential "from" point and converts it to be a similar point on the opposite side of the family's host from the "to" point if necessary.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- newFromLocation
- Type: Autodesk.Revit.DB XYZ
The desired "from" location
Return Value
The valid "from" location.Remarks
If the point is already an acceptable "from" location then the original point will be returned. Otherwise, the point's X and Y will be projected onto the centerline of the family's host.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |