Creates an arc through the given reference points.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The Document.
- startPoint
- Type: Autodesk.Revit.DB ReferencePoint
The start point of the arc.
- endPoint
- Type: Autodesk.Revit.DB ReferencePoint
The end end of the arc.
- interiorPoint
- Type: Autodesk.Revit.DB ReferencePoint
The interior point on the arc.
Return Value
The CurveElement to be created.Remarks
The interiorPoint determines the orientation of the arc while startPoint and endPoint determine the angle parameters at the ends.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | Can't create an arc from the given points |