CreateArcThroughPoints Method


Curve By Points Utils Create Arc Through Points Method

Creates an arc through the given reference points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static CurveElement CreateArcThroughPoints(
	Document document,
	ReferencePoint startPoint,
	ReferencePoint endPoint,
	ReferencePoint interiorPoint
)

Parameters

document Document
The Document.
startPoint ReferencePoint
The start point of the arc.
endPoint ReferencePoint
The end end of the arc.
interiorPoint ReferencePoint
The interior point on the arc.

Return Value

CurveElement
The CurveElement to be created.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException Can't create an arc from the given points
Remarks
The interiorPoint determines the orientation of the arc while startPoint and endPoint determine the angle parameters at the ends.
See Also