CreateArcThroughPoints Method


Creates an arc through the given reference points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static CurveElement CreateArcThroughPoints(
	Document document,
	ReferencePoint startPoint,
	ReferencePoint endPoint,
	ReferencePoint interiorPoint
)
Visual Basic
Public Shared Function CreateArcThroughPoints ( _
	document As Document, _
	startPoint As ReferencePoint, _
	endPoint As ReferencePoint, _
	interiorPoint As ReferencePoint _
) As CurveElement
Visual C++
public:
static CurveElement^ CreateArcThroughPoints(
	Document^ document, 
	ReferencePoint^ startPoint, 
	ReferencePoint^ endPoint, 
	ReferencePoint^ interiorPoint
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The Document.
startPoint
Type: Autodesk.Revit.DBReferencePoint
The start point of the arc.
endPoint
Type: Autodesk.Revit.DBReferencePoint
The end end of the arc.
interiorPoint
Type: Autodesk.Revit.DBReferencePoint
The interior point on the arc.

Return Value

The CurveElement to be created.

Remarks

The interiorPoint determines the orientation of the arc while startPoint and endPoint determine the angle parameters at the ends.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException Can't create an arc from the given points

See Also