Changes the size of the selection of fabrication parts.
Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2018.2
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- selection
- Type: System.Collections.Generic ISet ElementId
The set of element identifiers of fabrication parts to change the size for.
- fabricationPartSizeMaps
- Type: System.Collections.Generic ISet FabricationPartSizeMap
The map containing the original sizes for the straights to the new sizes.
Remarks
After this method has been invoked, call:
- GetStraightsThatWereNotChanged to get a set of fabrication part straight element identifiers that were not changed.
- GetElementsThatFailed to get a set of fabrication part element identifiers that had failures.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The selection contains invalid elements to change. -or- The fabrication size map is empty. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | No fabrication configuration is loaded. |