ChangeSize Method


Changes the size of the selection of fabrication parts.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018.2

Syntax

C#
public FabricationNetworkChangeServiceResult ChangeSize(
	ISet<ElementId> selection,
	ISet<FabricationPartSizeMap> fabricationPartSizeMaps
)
Visual Basic
Public Function ChangeSize ( _
	selection As ISet(Of ElementId), _
	fabricationPartSizeMaps As ISet(Of FabricationPartSizeMap) _
) As FabricationNetworkChangeServiceResult
Visual C++
public:
FabricationNetworkChangeServiceResult ChangeSize(
	ISet<ElementId^>^ selection, 
	ISet<FabricationPartSizeMap^>^ fabricationPartSizeMaps
)

Parameters

selection
Type: System.Collections.GenericISetElementId
The set of element identifiers of fabrication parts to change the size for.
fabricationPartSizeMaps
Type: System.Collections.GenericISetFabricationPartSizeMap
The map containing the original sizes for the straights to the new sizes.

Remarks

After this method has been invoked, call:

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The selection contains invalid elements to change. -or- The fabrication size map is empty.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException No fabrication configuration is loaded.

See Also