Fabrication |
Changes the size of the selection of fabrication parts.
Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public FabricationNetworkChangeServiceResult ChangeSize(
ISet<ElementId> selection,
ISet<FabricationPartSizeMap> fabricationPartSizeMaps
)
Parameters
- selection ISet ElementId
- The set of element identifiers of fabrication parts to change the size for.
- fabricationPartSizeMaps ISet FabricationPartSizeMap
- The map containing the original sizes for the straights to the new sizes.
Return Value
FabricationNetworkChangeServiceResult
Exception | Condition |
---|---|
ArgumentException | The selection contains invalid elements to change. -or- The fabrication size map is empty. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | No fabrication configuration is loaded. |

After this method has been invoked, call:
- GetStraightsThatWereNotChanged to get a set of fabrication part straight element identifiers that were not changed.
- GetElementsThatFailed to get a set of fabrication part element identifiers that had failures.