An enumerated type listing all the toolbar item styles.
Namespace:
Autodesk.Revit.UI
Assembly:
RevitAPIUI
(in RevitAPIUI.dll) Version: 19.0.0.0 (19.0.0.405)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
PushButton | A standard button with text and image. |
PulldownButton | A button with a pull-down menu list. |
SplitButton | A split button with a default button and a pull-down menu list. |
ToggleButton | A standard button that can be added to RadioButtonGroup. |
RadioButtonGroup | An item that contains a collection of RibbonToggleButton items. |
ComboBoxMember | An item in the drop-down list of a ComboBox. |
ComboBox | A selection control with a drop-down list that can be shown or hidden by clicking the arrow on the control. |
TextBox | A text-based control that allows the user to enter text. |