RibbonItemType Enumeration


Ribbon Item Type Enumeration

An enumerated type listing all the toolbar item styles.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum RibbonItemType
Members
Member name Value Description
PushButton 0 A standard button with text and image.
PulldownButton 1 A button with a pull-down menu list.
SplitButton 2 A split button with a default button and a pull-down menu list.
ToggleButton 3 A standard button that can be added to RadioButtonGroup.
RadioButtonGroup 4 An item that contains a collection of RibbonToggleButton items.
ComboBoxMember 5 An item in the drop-down list of a ComboBox.
ComboBox 6 A selection control with a drop-down list that can be shown or hidden by clicking the arrow on the control.
TextBox 7 A text-based control that allows the user to enter text.
See Also