RibbonItemType Enumeration


Ribbon Item Type Enumeration

An enumerated type listing all the toolbar item styles.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum RibbonItemType
Members
Member name Value Description
ComboBox 6 A selection control with a drop-down list that can be shown or hidden by clicking the arrow on the control.
ComboBoxMember 5 An item in the drop-down list of a ComboBox.
PulldownButton 1 A button with a pull-down menu list.
PushButton 0 A standard button with text and image.
RadioButtonGroup 4 An item that contains a collection of RibbonToggleButton items.
SplitButton 2 A split button with a default button and a pull-down menu list.
TextBox 7 A text-based control that allows the user to enter text.
ToggleButton 3 A standard button that can be added to RadioButtonGroup.
See Also