IsSketchEditingSupported Method


Checks whether sketch can be edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022

Syntax

C#
public bool IsSketchEditingSupported(
	ElementId sketchId
)
Visual Basic
Public Function IsSketchEditingSupported ( _
	sketchId As ElementId _
) As Boolean
Visual C++
public:
bool IsSketchEditingSupported(
	ElementId^ sketchId
)

Parameters

sketchId
Type: Autodesk.Revit.DB ElementId
The element id of sketch.

Return Value

True if sketch can be edited, false otherwise.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also