Checks whether sketch can be edited.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- sketchId
- Type: Autodesk.Revit.DBElementId
The element id of sketch.
Return Value
True if sketch can be edited, false otherwise.Remarks
This method checks if this particular sketch can be edited. If you want to check if all sketches of an element can be edited please use IsSketchEditingSupportedForSketchBasedElement(ElementId)
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |