Sketch |
Checks whether sketch can be edited.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- sketchId ElementId
- The element id of sketch.
Return Value
BooleanTrue if sketch can be edited, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

This method checks if this particular sketch can be edited. If you want to check if all sketches of an element can be edited please use IsSketchEditingSupportedForSketchBasedElement(ElementId)