Returns a transform representing the movement of the bar relative to its default position along the distribution path.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- barPositionIndex
- Type: System Int32
The bar index.
Return Value
The transform representing the movement of the bar relative to its default position along the distribution path.Remarks
For a RebarInSystem for which individual bars can't be edited (the ones owned by AreaReinforcement) the identity transform is returned.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ]. |