Rebar |
Returns a transform representing the movement of the bar relative to its default position along the distribution path.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- barPositionIndex Int32
- The bar index.
Return Value
TransformThe transform representing the movement of the bar relative to its default position along the distribution path.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ]. |

For a RebarInSystem for which individual bars can't be edited (the ones owned by AreaReinforcement) the identity transform is returned.