Calculates the extrusion data from a Revit geometry object.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- extrusionOptions
- Type: Autodesk.Revit.DB.IFC IFCExtrusionCalculatorOptions
The options for extrusion extraction.
- geometryObject
- Type: Autodesk.Revit.DB GeometryObject
The geometry object.
Return Value
A collection of extrusion data calculated for the geometry. If the function fails to calculate one or more valid extrusions, this collection will be empty.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |