Calculates the extrusion data from a Revit geometry object.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- extrusionOptions
- Type: Autodesk.Revit.DB.IFCIFCExtrusionCalculatorOptions
The options for extrusion extraction.
- geometryObject
- Type: Autodesk.Revit.DBGeometryObject
The geometry object.
Return Value
A collection of extrusion data calculated for the geometry. If the function fails to calculate one or more valid extrusions, this collection will be empty.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |