IFCExtrusion |
Calculates the extrusion data from a Revit geometry object.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)

public static IList<IFCExtrusionData> CalculateExtrusionData(
IFCExtrusionCalculatorOptions extrusionOptions,
GeometryObject geometryObject
)
Parameters
- extrusionOptions IFCExtrusionCalculatorOptions
- The options for extrusion extraction.
- geometryObject GeometryObject
- The geometry object.
Return Value
IList IFCExtrusionDataA collection of extrusion data calculated for the geometry. If the function fails to calculate one or more valid extrusions, this collection will be empty.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |