GetModeOverride Method


Lookup color settings for the given color mode.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public PointCloudColorSettings GetModeOverride(
	PointCloudColorMode mode
)
Visual Basic
Public Function GetModeOverride ( _
	mode As PointCloudColorMode _
) As PointCloudColorSettings
Visual C++
public:
PointCloudColorSettings^ GetModeOverride(
	PointCloudColorMode mode
)

Parameters

mode
Type: Autodesk.Revit.DB PointCloudColorMode
Color mode for which to lookup the color settings.

Return Value

Color settings stored for the given color mode or default color settings if nothing is stored for the given color mode.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also